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Aloha POS: Incorrect Proxy Settings Can Prevent Olo from Connecting


Updated

Audience:

Technical Teams, Client's POS/IT Support

Description of Issue:

OloAlohaService will start but will not connect to Olo servers and the log reports the following errors:

System.Net.WebException: The remote server returned an error: (400) Bad Request.

followed by:

Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.

 

Cause:

One or more Aloha processes may change the proxy server settings for the service user account causing that user to be unable to access the internet.

 

Resolution:

Correct the proxy settings for the service user.

  1. Determine the username of the service user by opening up Windows Services and looking at the value in the "Log On As" column. (Red dot below.)
  2. Log out of Windows on your Aloha BOH server.
  3. Log in to Windows with the username identified in step 1. (You may need to contact your support channel for assistance in obtaining the password if you do not know it.)
  4. Open Control Panel, set the view to "Small Icons" (green dot below), and then click on Internet Options (red dot below).
  5. In the Internet Properties window that opened, click on the "Connections" tab and then the "LAN Settings" button.
  6. Uncheck all boxes, then click OK.
  7. Click OK one more time to exit the Internet Properties window.
  8. Log out of Windows and log back in as a user with administrator rights.
  9. Restart the OloAlohaService.
  10. Vendor should now appear Online and Connected in Dashboard.

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