Back to Olo.com

Error Message: 400 Bad Request


Audience:

Technical Teams, Account Managers, Product Development

Description:  

Vendor passes tests, but when service starts, connection to Olo Servers fails and returns this error: 400 Bad Request


Resolution:

Troubleshoot while logged in as the Windows user your service is logging in with 

Specifically for the error 400 issue:

1. First checkpoint on the Olo side is for the Olo Specialist to confirm there is not a trailing space in the POS Username. If confirmed that the POS Username in the local config file and password are correct, move to #2.

2. If you see a network error (like a 400 bad request), log in to the AlohaSVC user account (or whatever account you use to set up the OLO services.

3. Open all browsers and clear cache and cookies to eliminate any temp file corruption errors that could be causing the issue. (This was the suggestion from many online forums but it was not our issue at all.  Still a good step to take anyway just to be certain.)

4. Open up your Internet Options from the browser, then navigate to Network Settings > LAN Settings and verify that the “proxy” setting is not checked OR if you are using a proxy, that it is configured properly.

5. Restart the OLO services and verify everything reconnects properly

Troubleshoot while logged in as the Windows user your service is logging in with. 

 

 

Didn't find what you need?

Submit a request to our Help Team and someone will
get back to you shortly.

Submit a request

Copyright © 2018 Olo. All rights are reserved.