Back to Olo.com

MICROS: "Could not connect to RES API" Error


Audience:

Technical Teams, Customer Success Teams, and Brand's POS programmer
   

Objective:

The purpose of this article is to provide a solution when a vendor is not able to take online orders due to this error in the Olo log: 

Validation error(s):  Could not connect to RES API at http://localhost/ResPosApiWeb/ResPosApiWeb.asmx. The remote server returned an error: (500) Internal Server Error.

This error is caused when MICROS can not access the RES API on the micros server.  This is not an Olo issue but one with micros that will stop any RES API communication.

 

Solution:

The following steps have proven to resolve this issue.  If they do not, please reach out to your MICROS 3700 support team.  

Step 1

Confirm that the reported error is correct by opening that URL in Internet Explorer.  

res_api_error_IE.png


Step 2

Attempt to resolve this error by a restart the IIS services.
  • Login into windows as an Administrator

  • Go to a command/DOS prompt (type cmd from the run menu)

  • Type iisreset and press enter

Step 3

Test if this solution was successful.

valid_res_api_url.png

 

Step 4

If the above steps were unsuccessful, the last attempt at self resolution is to perform reboot of your micros server.

  • Open the MICROS Control Panel

  • Select, and confirm, the Off option
  • When you see all red X's, close the control panel

  • Perform a Windows reboot

Step 5

Confirm that a reboot resolved the issue

  • Repeat step 3

  • If unsuccessful, contact your micros support team for assistance.

Didn't find what you need?

Submit a request to our Help Team and someone will
get back to you shortly.

Submit a request

Copyright © 2018 Olo. All rights are reserved.